1.0.8 Has Arrived!

Here are the new features of 1.0.8:

*** Now requires iOS 6 ***

Almost all of our users are already using iOS 6, so this shouldn’t be a problem. If you cannot upgrade to iOS 6 for some reason, keep the previous version of the game.

We now make better use of iOS 6’s new Game Center features.